Project

General

Profile

Actions

Bug #1231

closed

gj_jb Table Missing

Added by ckayfish about 13 years ago. Updated almost 13 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
Start date:
19 August 2009
Due date:
% Done:

100%

Estimated time:

Description

When I create a new group, the forum is created in the assigend parent in Kunena, however there is no link to this forum in the group.

It looks like the fuction that build the links on the group page is in groupjive_func.php. It is selecting from a table called #__gj_jb. I do not have this table, neither the XML file of the component or the plugin has the CREATE statement for this table. I can see that this insert table is in the plugin, but since the table doesn't exist it's a no go.

Actions #1

Updated by ckayfish about 13 years ago

The intended table structure may be different (e.g. would we need a primary key?) but I craeted the table with following statement and new groups now have link since gj_jb exists and is being populated.

CREATE TABLE `jos_gj_jb` ( `id` int(10) unsigned NOT NULL auto_increment, `group_id` int(10) NOT NULL default '0', `category_id` int(10) NOT NULL default '0', PRIMARY KEY (`id`) ) TYPE=MyISAM AUTO_INCREMENT=1;

Before I proceed I will wait for word on what the official CREATE statement should look like.

Actions #2

Updated by krileon almost 13 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100

Resolved in B5.

Quickfix!

Run the following query in your database (change prefix if needed)
CREATE TABLE IF NOT EXISTS `jos_gj_jb` (
`id` int(11) unsigned NOT NULL auto_increment,
`group_id` int(11) default NULL,
`category_id` int(11) default NULL,
PRIMARY KEY (`id`)
) TYPE=MyISAM AUTO_INCREMENT=1;

Actions #3

Updated by krileon almost 13 years ago

  • Target version set to 1.8 B5
Actions #4

Updated by krileon almost 13 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF