Project

General

Profile

Actions

Bug #3189

closed

Step by step tab fatal JS error

Added by krileon over 10 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
24 January 2012
Due date:
% Done:

100%

Estimated time:

Description

IN: components/com_comprofiler/plugin/user/plug_cbconditional/js/cbconditional.min.js
ON: Line 1
$("#cbtf_" + tab_id).parent(".ui-tabs-panel").attr("id") is undefined

In some cases a fatal error can occur resulting in the above. Additional checks need to be made to ensure the tab page is a jQuery object.

http://www.joomlapolis.com/forum/153-professional-member-support/188761-cbsubs-and-registration-step#188944

Actions #1

Updated by krileon over 10 years ago

  • Subject changed from Step by step tab fatal JS error - UNCONFIRMED to Step by step tab fatal JS error
  • Target version set to 1.3.1

Is due to using CB Captcha 2.2, install for testing as there should be a check to test the tab object before attempting to return any attributes from it.

Actions #2

Updated by krileon over 10 years ago

This is due to a Replace action being done on an undefined attribute. Need to put an IF check to ensure it only happens if something is available to replace.

Actions #3

Updated by krileon over 10 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100
Actions #4

Updated by krileon over 10 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF