Project

General

Profile

Actions

Bug #3665

closed

Tab conditions working opposite of what is configured in profile edit

Added by krileon almost 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
24 August 2012
Due date:
% Done:

100%

Estimated time:

Description

2 way tab conditions not working properly. For example a tab is configured to hide if a checkbox is empty. This works fine in profile view, but in profile edit even though the checkbox is checked (not empty) it is still hidden, but suddenly shows if the checkbox us unchecked (empty).

https://www.joomlapolis.com/forum/153-professional-member-support/208543-cb-conditional-viewedit-12-ways

Actions #1

Updated by krileon almost 10 years ago

  • Target version set to 1.8.7
Actions #2

Updated by krileon almost 10 years ago

Appears to be a bug in the JS value matching as profile edit uses strictly the JS except for on POST to handle display.

Actions #3

Updated by krileon almost 10 years ago

An operator of "6" (empty) was selected, but JS is outputting the operator is "1" (not equal to). For some strange reason it's not being passed the correct operator.

Actions #4

Updated by krileon almost 10 years ago

Found the issue, direction was being declared as operator instead of direction when defining the JS parameters.

Actions #5

Updated by krileon almost 10 years ago

  • Status changed from Assigned to Closed
  • % Done changed from 0 to 100

Now working as intended. Quickfix as follows.

IN: components/com_comprofiler/plugin/user/plug_cbconditional/cbconditional.class.php
ON: Line 655
FROM:
"operator: " . (int) $direction . ","
TO:
"direction: " . (int) $direction . ","

Actions

Also available in: Atom PDF