Project

General

Profile

Actions

Bug #3717

closed

CBSubs fails if conditionals present on registration

Added by krileon almost 10 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Immediate
Assignee:
Target version:
Start date:
08 October 2012
Due date:
% Done:

100%

Estimated time:

Description

If any sort of field conditional is present at time of registration it results in CBSubs failing. This appears to be due to user object being altered at some point and CBSubs is receiving a blank user.

https://www.joomlapolis.com/forum/153-professional-member-support/210888-no-subscriptions-created-after-registration?limit=6&start=18

Actions #1

Updated by krileon almost 10 years ago

This is occurring in the fieldsFetch function of tab.cbconditional.php. Once the trigger to utilize it is commented out the issue resolves. Perhaps is due to field value reset.

Actions #2

Updated by krileon almost 10 years ago

It's due to bindThisUserFromDbArray on the cbUser object. This needs to be reset to previous or be carefully set.

Actions #3

Updated by krileon almost 10 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Had to re-implement a usage from 1.8.9 for handling of POST data when checking for field values. Generalized function created to now handle this, confirmed working.

Actions #4

Updated by krileon almost 10 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF