Project

General

Profile

Actions

Bug #4286

closed

Load module does not function inside CB IF substitutions

Added by krileon about 8 years ago. Updated about 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
16 October 2013
Due date:
% Done:

100%

Estimated time:

Description

The REGEX to check for open and closing tag is likely the cause of this. Load module causes the substitution usage to stop working as it's probably ending at the end of the load module tag. The REGEX should be improved to grab the last closing tag instead of the first occurrence to prevent this.

https://www.joomlapolis.com/forum/154-advanced-members-support/222959-time-released-subscription-content-solution-loadposition-module-content-throws-cb-logic

Actions #1

Updated by krileon about 7 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

This is due to the regex being lazy and going to } as few as possible. It needs to be changed to greedy so it goes until the last }.

Actions #2

Updated by krileon about 7 years ago

  • Status changed from Resolved to Closed
  • Target version set to 3.0.0
Actions

Also available in: Atom PDF