Project

General

Profile

Bug #1246

Kunena Forum Permission Problems and Kunena Frontend Display Issues

Added by ComposerRyan about 11 years ago. Updated almost 11 years ago.

Status:
Closed
Priority:
High
Assignee:
-
Target version:
Start date:
25 August 2009
Due date:
% Done:

100%

Estimated time:

Description

Joomla! 1.5.14 Stable
Kunena 1.5.5
Community Builder 1.2.1
GroupJive 1.8 B4

THE PROBLEM: When creating a group, the forum is automatically created in Kunena according to the Kunena administration accessed via the backend of Joomla. However, when going to the frontend, the forum does not show under the category. Under the Integration Tab in the Groupjive administration, I have ensured that "Show Forums" is properly set to "Yes" In some random occurrences, the forums do display in the Kunena frontend. At times, when logging into other usernames on my website, all of the forums will display. And while logging in underneath yet another username, only 1 or none of the forums will display at all in the Kunena frontend. I have made sure the parent category ID and show forum settings are set properly in the GroupJive intergration tab. Also, when in the group's page, there is no link to the group's forum. Therefore, at present, there is no real way to even access these forums.

THE POSSIBLE CAUSE: I noticed that the forums in the Kunena Administration have Public Access and Admin Access set to "Public Backend" When set to "Registered Only" it display properly. It seems that it need to be set to "Registered Only" or something else. Then, everyone would be able to see the forums listed in the parent category. But, of course, if the member is not a part of that group's forum, they should not be allowed to access it. This was implemented in a hack for GroupJive and Fireboard and worked great.

FURTHER TESTING: What also needs to be tested is to see if, currently, members can have access to other group's forums even if they are not members of those groups. If this is the case, than simply accessing the URL of the group's forum is possible allowing ANYONE to post. This issue needs to be addressed, if it does indeed exist. If a user is trying to access a forum of a group they do not belong to, they need to be blocked and a notice needs to display informing them, "You are not allowed to view this forum because you are not a member of that group. Please join the group to view this forum."

History

#1 Updated by ComposerRyan about 11 years ago

Please note that Joomla 1.5.14 is running in legacy mode.

#2 Updated by krileon about 11 years ago

  • Status changed from New to Feedback
  • Priority changed from High to Low

I believe you've misunderstood the usage of the forum integration.

It creates a category under a parent category, which is meant to be hidden, not seen in kunenas category display. This is intentional and not going to be removed. If there's 1000 groups, then you'll have a page with over 1000 categories. There is a link inside the group that goes directly to the forums, under the hood checks are made, it is not just a direct link.

While the Fireboard hack may have worked exactly the way you wanted, we do NOT support hacks and thus this method was removed entirely for one that uses Kunena, CB, and GroupJive API; no hacks involved.

When a user tries to access a group forum, checks are in place to ensure they are a member of that group and will then give them access.

The integration has been fully tested.

#3 Updated by Rapunzl about 11 years ago

  • Status changed from Feedback to New
  • Priority changed from Low to High

I can confirm this bug, with a clean GroupJive install. Only the GroupJive component (B4) and plugin are installed, but there is no link to the forums, whether the Groups forum category is set to published or not. Kyle, feel free to message me for SA access.

I did NOT remove the old Kunena tables, but I did try with the same results both before and after deleting the old GroupJive tables. I have a backup of the old GJ tables to restore if needed.

Update: I restored my old GJ tables, and it works. Is it possible new installs have a problem? I'll do some more testing with a fresh install of Joomla/CB/Kunena/GJ.

#4 Updated by Rapunzl about 11 years ago

This looks to be the same issue as Bug 1231, where ckayfish has provided a fix that should be included in the release?

#5 Updated by krileon about 11 years ago

  • Status changed from New to Feedback

Looks to be related to #1231, which is resolved. Yes fix is provided in up coming release.

#6 Updated by krileon almost 11 years ago

  • % Done changed from 0 to 100

#7 Updated by krileon almost 11 years ago

  • Status changed from Feedback to Resolved

#8 Updated by krileon almost 11 years ago

  • Target version set to 1.8 B5

#9 Updated by krileon almost 11 years ago

  • Status changed from Resolved to Closed

Also available in: Atom PDF