Project

General

Profile

Actions

Bug #5047

closed

Invalid conditions causing fatal error

Added by krileon over 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
Start date:
27 January 2015
Due date:
% Done:

100%

Estimated time:

Description

An invalid condition seams to be able to lock profile edit. I'm unsure what condition is specifically doing it, but needs further investigate to see if it can be avoided.

https://www.joomlapolis.com/forum/153-professional-member-support/228279-fatal-error-cannot-access-empty-property#257780

I'm pretty sure it's due to the $postUser when it's binding the POST array.

Actions #1

Updated by krileon over 7 years ago

  • Target version changed from 4.0.5 to 4.0.6
Actions #2

Updated by krileon about 7 years ago

If a condition is configured to conditional self with no field or conditional others with no fields then it can cause the below error.

Fatal error: Cannot access empty property in /libraries/CBLib/CB/Database/Table/UserTable.php on line 290

Actions #3

Updated by krileon over 6 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Caused by getFieldValue trying to grab the value of a field that doesn't exist. Now treats non-existent fields as null.

Actions #4

Updated by krileon over 6 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF