Project

General

Profile

Actions

Bug #6679

closed

Honeypot only mode fails validation

Added by krileon over 5 years ago. Updated over 4 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
22 June 2017
Due date:
% Done:

100%

Estimated time:

Description

When using Honeypot (Internal) the validation always fails. Note untested, but reported below.

https://www.joomlapolis.com/forum/255-developer-members-support/236840-another-undefined-method-guzzle-problem#295051

Actions #1

Updated by krileon about 5 years ago

  • Status changed from Assigned to Rejected
  • Target version deleted (3.1.0)
  • % Done changed from 0 to 100

Works fine in all test cases. My guess is something may have been filling the honeypot input (browser autofill?) or the honeypot name was conflicting with an actual field.

Actions #2

Updated by krileon over 4 years ago

  • Status changed from Rejected to Resolved
  • Target version set to 3.2.0

Was able to find and confirm the cause. It was due to ->input not caching the captcha instance, which was only happening in ->captcha. Now when trying to grab the input or the image it will properly generate a captcha code and cache as needed.

Actions #3

Updated by krileon over 4 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF