Project

General

Profile

Actions

Bug #8023

open

PayPal Standard: recurring payments with address sent using a London postal code fails

Added by krileon over 2 years ago. Updated 4 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Target version:
Start date:
20 May 2020
Due date:
% Done:

0%

Estimated time:

Description

When attempting to subscribe to a plan that only allows recurring payments with a PayPal Standard gateway that also only allows recurring payments while sending invoice address and using a London postal code formatted as "## ###" causes the payment to fail. The user is presented with a generic "Things don't appear to be working at the moment. Please try again later." no information is given to the site via IPN or history log and no further information is given to the user that the postal code being sent in the "zip" form parameter is failing. Turning off sending of invoice address appears to resolve the issue.

https://www.joomlapolis.com/forum/255-developer-members-support/242408-solved-is-it-possible-to-use-different-gateway-behaviours-for-different-plans?start=6#318658

Actions #1

Updated by beat about 2 years ago

  • Target version changed from 4.4.0 to 4.5.0
Actions #2

Updated by krileon about 2 years ago

  • Status changed from New to Rejected
  • Target version deleted (4.5.0)
  • % Done changed from 0 to 100
Actions #3

Updated by krileon about 2 years ago

  • Status changed from Rejected to New
  • Target version set to 4.5.0
  • % Done changed from 100 to 0

Re-opened just to keep an eye on the issue. Seams to have been an intermittent issue on PayPals end, but will keep track of the issue here.

Actions #4

Updated by krileon about 2 years ago

Maybe caused by #8038. Hard to know exactly due to vagueness of the errors.

Actions #5

Updated by beat over 1 year ago

  • Target version changed from 4.5.0 to 4.5.1
Actions #6

Updated by beat over 1 year ago

  • Target version changed from 4.5.1 to 4.5.2
Actions #7

Updated by beat about 1 year ago

  • Priority changed from High to Normal
Actions #8

Updated by beat about 1 year ago

  • Target version changed from 4.5.2 to 4.5.3
Actions #9

Updated by beat 8 months ago

  • Target version changed from 4.5.3 to 4.6.0
Actions #10

Updated by beat 4 months ago

  • Target version changed from 4.6.0 to 4.6.1
Actions #11

Updated by beat 4 months ago

  • Target version changed from 4.6.1 to 4.6.2
Actions

Also available in: Atom PDF