Project

General

Profile

Actions

Bug #8224

open

Expired subscriptions login check happens before confirmed/approved check

Added by krileon almost 2 years ago. Updated 4 months ago.

Status:
Resolved
Priority:
Urgent
Assignee:
Target version:
Start date:
04 November 2020
Due date:
% Done:

90%

Estimated time:

Description

When logging in with a plan that requires confirmation/approval before payment the checkExpireMe function in onDuringLogin will redirect the user away if "Allow Free Registered Users (without subscriptions)" is not set to "Yes" to accountexpired page and allows collecting payment despite user not being confirmed/approved. This shouldn't be happening. The checkExpireMe check should be done after onDuringLogin behavior is done with its checks.

Actions #1

Updated by krileon almost 2 years ago

  • Status changed from New to Resolved
  • Assignee set to krileon
  • % Done changed from 0 to 100

Fixed in MR !208

Actions #2

Updated by beat over 1 year ago

  • Assignee changed from krileon to beat
  • Target version changed from 4.5.0 to 4.5.1
  • % Done changed from 100 to 90

Looking at code there seems to be some edge cases, needing more careful review and tests before merging, so I will continue doing this after 4.5.0 release.

Actions #3

Updated by beat over 1 year ago

  • Status changed from Resolved to Closed
Actions #4

Updated by beat about 1 year ago

  • Status changed from Closed to Resolved
  • Target version changed from 4.5.1 to 4.5.3
Actions #5

Updated by beat 8 months ago

  • Target version changed from 4.5.3 to 4.6.0

missed that pending one for 4.5.3, moving to 4.6.0.

Actions #6

Updated by beat 4 months ago

  • Target version changed from 4.6.0 to 4.6.1
Actions #7

Updated by beat 4 months ago

  • Status changed from Resolved to Closed
Actions #8

Updated by beat 4 months ago

  • Target version changed from 4.6.1 to 4.6.2
Actions #9

Updated by beat 4 months ago

  • Status changed from Closed to Resolved
Actions

Also available in: Atom PDF