Project

General

Profile

Actions

Bug #8619

closed

In activity stream in Groups for

Added by beat 5 months ago. Updated 5 months ago.

Status:
Rejected
Priority:
Urgent
Assignee:
Target version:
-
Start date:
09 July 2021
Due date:
% Done:

100%

Estimated time:

Description

On activity in groups, the privacy selection is not respected:

Steps to reproduce:

1. Lgoin as Demo user at https://demo.cbdemosites.com/demos/cb-groupjive/all-categories/1-community-builder-add-ons/26-cb-template-changer
2. Click on "what's on your mind?" field at top, write a message, select "Connections" as privacy and psot
3. Logout and click the "go to previous page" of browser button

Expected result:
- Post invisible

Actual result:
- Post visible.

It works correctly with Private, Users and Public, but not wit "Connections".

This users says that it also doesn't work with "Private" but I couldn't reproduce that by logging in with different user, can't see it:

https://www.joomlapolis.com/forum/153-professional-member-support/244108-privacy-at-gj#325592

Actions #1

Updated by krileon 5 months ago

  • Status changed from Assigned to Rejected
  • Target version deleted (955)
  • % Done changed from 0 to 100

Connections appears working fine. Edited post and was set to Public, changed to Connections, saved, and logged out and appears hidden as it should be.

See #8617 for topic issue regarding notifications not checking post privacy. Activity privacy is also controlled by CB Privacy and implemented by CB Auto Actions and not in CB Activity itself.

Actions

Also available in: Atom PDF