Project

General

Profile

Actions

Bug #8790

closed

Workaround novel PayPal.com bug: basket item name fraud check fails if name contains special characters

Added by krileon 8 months ago. Updated 8 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
01 December 2021
Due date:
% Done:

100%

Estimated time:

Description

This fraud check probably isn't necessary and might be better to use a better method for detecting authenticity of a payment (or not doing so at all and instead verifying the IPN signature and accepting the data).

https://www.joomlapolis.com/forum/255-developer-members-support/244518-cbsubs-paypal-and-special-characters#327303

Actions #1

Updated by beat 8 months ago

As reproduced on Paypal Sandbox:

Error returned is like:

Payment notification mismatch: currency, item name or number or quantity mismatch: IPN item_name (Donation for test2 uk) 
does not match basket item_name (Donation for test2 Łuk) nor their trimmed sizes for IPN (Donation for test2 uk) and basket
(Donation for test2 Łuk) nor their url-decoded form (Donation for test2 uk).

This is a Paypal.com bug:

It is due to PDT callback "_notify_synch" returning results in Windows-1252 charset instead of UTF-8 as before, so incompatible characters are transformed into %1A (SUB - subtitute) encoding.

Working on workaround.

Actions #2

Updated by beat 8 months ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Fixed in commit 314f25a0d02b8a23bbd67cced34a7243ea082785

Actions #3

Updated by beat 8 months ago

  • Subject changed from PayPal: basket item name fraud check fails if name contains special characters to Workaround novel PayPal.com bug: basket item name fraud check fails if name contains special characters
Actions #4

Updated by beat 8 months ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF