Project

General

Profile

Actions

Bug #8815

closed

Stripe: lost disputes not cancelling subscriptions at Stripe

Added by krileon about 2 years ago. Updated 7 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
17 December 2021
Due date:
% Done:

100%

Estimated time:

Description

Disputes lost immediately during charge.dispute.created never fire charge.dispute.closed. The current handling does not handle status in charge.dispute.created resulting in the dispute being treated as in a pending state. The result is recurring subscriptions get paused instead of cancelled due to dispute being lost.

Actions #1

Updated by beat almost 2 years ago

  • Target version changed from 4.6.0 to 4.6.1
Actions #2

Updated by beat almost 2 years ago

  • Target version changed from 4.6.1 to 4.6.2
Actions #3

Updated by krileon about 1 year ago

Finally confirmed. This is due to a dispute lost immediately when it's created. The result is charge.dispute.closed event is never sent.

Actions #4

Updated by krileon about 1 year ago

  • Description updated (diff)
Actions #5

Updated by krileon about 1 year ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Fixed in MR !285

Actions #6

Updated by beat 7 months ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF