Project

General

Profile

Actions

Bug #8849

closed

Price filters in payment center table cause fatal SQL error

Added by krileon 7 months ago. Updated 4 months ago.

Status:
Closed
Priority:
High
Assignee:
Target version:
Start date:
28 January 2022
Due date:
% Done:

100%

Estimated time:

Description

When clicking a price under "Completed" column (also errors for "Pending", but not for "Paid on") in the "last 7 days payments" table an error is thrown as follows.

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ''Completed' ) AND ( a.`time_paid_date` = '2022-01-21' ) AND ( a.`payment_status`' at line 4

The filters attempting to be applied to the payments table (&table=payments) are as follows.

[filter_payment_status]=Completed
[filter_time_paid_date]=2021-07-12

https://www.joomlapolis.com/forum/277-cb-paid-subscriptions-support/244632-you-have-an-error-in-your-sql-syntax

Actions #2

Updated by beat 6 months ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Fixed in commit 80112ae00deb2b0c74b38219c94f5887c9414ef0

Was a regression due to a recent nightly commit: the filter for payment status in payments table changed to accept multiple statuses, but didn't change link to array. As in payments not very useful, and linked throughout CBSubs, reverted that multiple choice.

Actions #3

Updated by beat 4 months ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF