Project

General

Profile

Bug #2744

Chrome browser: Javascript error in on user profiles: "Uncaught SyntaxError: Unexpected token { from overlib_all_mini.js line 340"

Added by beat about 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
31 August 2011
Due date:
% Done:

100%

Estimated time:
1:00 h

Syntax_Error_-_Chrome.zip (1.27 KB) Syntax_Error_-_Chrome.zip cubiq069, 10 October 2011 11:53 AM
27440-2.17.patch (2.33 KB) 27440-2.17.patch krileon, 19 October 2011 07:57 PM
27440-2.21.patch (60.8 KB) 27440-2.21.patch krileon, 19 October 2011 07:57 PM

Related issues

Related to CB - Bug #4097: Chrome overlib error Unexpected end of inputClosed2013-07-05

History

#1 Updated by cubiq069 about 9 years ago

Hi,

I provide a patch for this bug (for Community Builder 1.4)

BOUDAOUI Mohamed,
www.cubiq.fr

#2 Updated by krileon about 9 years ago

Patch provided does not work. The problem is how the replacement is handled. The code is taking an existing function then parsing it and changing it. The problem with this is how the parsing happens is completely browser based as they all output and handle the function differently. It works fine in IE and FF because both browsers decompressed the function then it's modified. Chrome however passes the original compressed version of the function (probably best practice actually). Attached is proposed fixed to simply decompressed that single function, which tested and confirmed working; this prevents major changes to the source!

Attached is also a patched updated version of overlib as latest is 2.21 while we use 2.17. Both tested and confirmed working.

#3 Updated by beat almost 9 years ago

  • Subject changed from Javascript error in Chrome on user profiles: "Uncaught SyntaxError: Unexpected token { from overlib_all_mini.js line 340" to Chrome browser: Javascript error in on user profiles: "Uncaught SyntaxError: Unexpected token { from overlib_all_mini.js line 340"
  • Status changed from Resolved to Closed

Fixed in r1582 .

Also available in: Atom PDF