Project

General

Profile

Actions

Bug #5874

closed

jQuery Validate skips a radio/checkbox input if 1 option hidden

Added by krileon almost 6 years ago. Updated about 5 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
22 March 2016
Due date:
% Done:

100%

Estimated time:

Description

When using a radio or multicheckbox field and the first option is hidden it cuases the required validation to be ignored for the input. For example in CBSubs have the first plan set to hide and marked exclusive then have the second plan visible and marked exclusive. The jQuery validation will skip the CBSubs plan selector input.

Actions #1

Updated by beat almost 6 years ago

  • Target version changed from CB 2.0.14 to CB 2.0.15
Actions #2

Updated by beat over 5 years ago

  • Target version changed from CB 2.0.15 to CB 2.1
Actions #3

Updated by krileon over 5 years ago

Needs retesting as this scenario seams working fine now.

Actions #4

Updated by krileon about 5 years ago

Confirmed, but seams to only specifically affect CBSubs oddly enough. Radio fields and Multi-Checkbox fields work fine even with first value hidden.

Actions #5

Updated by krileon about 5 years ago

Seams to be a deeper issue present. The form isn't validating most fields correctly on pressing submit. Appears to be due to cbremote check.

Actions #6

Updated by krileon about 5 years ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Fixed in MR !1182

Actions #7

Updated by krileon about 5 years ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF