Project

General

Profile

Bug #7432

Language finder not working unless backend language is default

Added by krileon over 1 year ago. Updated about 1 month ago.

Status:
Feedback
Priority:
Normal
Assignee:
-
Target version:
Start date:
22 January 2019
Due date:
% Done:

0%

Estimated time:

Description

If backend language is anything other than English (default) then the language finder fails to find any strings. This shouldn't matter though with the reset loading behavior changes in the finder.

https://www.joomlapolis.com/forum/153-professional-member-support/240412-language-overrides#310062

History

#1 Updated by krileon over 1 year ago

  • Priority changed from Normal to Low

Unable to confirm. Set backend to Japanese. Then searched nl-BE CB language plugin fine.

#2 Updated by krileon over 1 year ago

  • Priority changed from Low to Normal

Ok, was able to confirm this by setting backend Joomla language to nl-BE then attempting to search the CB language plugin nl-BE. Result is no results.

#3 Updated by krileon over 1 year ago

It's purely due to case sensitivity. It's being converted to nl-be instead of nl-BE.

#4 Updated by krileon over 1 year ago

The language finder XML needs to just pass plugin element instead of plugin folder to the finder. This doesn't work for CBSubs language plugins though as they have a element of cbsubs-nl-NL but a folder of cbpaidsubscriptions-nl-nl.

#5 Updated by krileon over 1 year ago

CBTxt it self needs improved as there's no reason it to be case sensitive for language tag.

#6 Updated by krileon over 1 year ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Fixed in MR !1454

The fix is to normalize language tag in CBTxt to lowercase.

#7 Updated by beat over 1 year ago

  • Status changed from Resolved to Closed

#8 Updated by krileon about 1 month ago

  • Status changed from Closed to Feedback
  • Assignee deleted (krileon)
  • Target version changed from CB 2.4.1 to CB 2.4.6
  • % Done changed from 100 to 0

Re-opening as this has yet to be merged. This still needs fixed. The issue is caused by language tags not being normalized which cases case sensitive loading issues.

Also available in: Atom PDF