Project

General

Profile

Actions

Bug #8823

closed

Deleting a user does not cancel recurring payments

Added by krileon 8 months ago. Updated 4 months ago.

Status:
Closed
Priority:
Immediate
Assignee:
Target version:
Start date:
03 January 2022
Due date:
% Done:

100%

Estimated time:

Description

Deleting a user should cancel any internal recurring schedulers for baskets the user owns (e.g. Quickpay uses the internal scheduler) and should cancel recurring of external schedulers (e.g. PayPal, Stripe, etc..). Basically loop each basket they own and call stopPaymentSubscription.


Related issues 2 (0 open2 closed)

Related to CB Paid Subscriptions - Bug #1437: Auto-recurring subscriptions: Cancellations: Offer to cancel only the recurring payments, in addition of subscription cancellationClosedbeat09 February 2010

Actions
Is duplicate of CB Paid Subscriptions - Feature proposal #8338: Deleting a subscription in user management should cancel recurring paymentsClosedbeat11 January 2021

Actions
Actions #2

Updated by beat 7 months ago

  • Status changed from Assigned to Resolved
  • % Done changed from 0 to 100

Fixed in commit 208cd2f4c899ed3f97c3cb57140e16a6e3309555
and tested with Paypal.

Actions #3

Updated by beat 7 months ago

  • Is duplicate of Feature proposal #8338: Deleting a subscription in user management should cancel recurring payments added
Actions #4

Updated by beat 7 months ago

Improvements in:
commit 71e8ceb3af29303bb3aa60eb697403f7ed3515f4 and commit c6e30138e2e59c9d787e5464c0fb114d38b0fd58

Actions #5

Updated by beat 7 months ago

  • Related to Bug #1437: Auto-recurring subscriptions: Cancellations: Offer to cancel only the recurring payments, in addition of subscription cancellation added
Actions #6

Updated by beat 4 months ago

  • Status changed from Resolved to Closed
Actions

Also available in: Atom PDF