Project

General

Profile

Bug #2950

CB Mass email loses users when using advanced is any of filtering on select field

Added by nant almost 9 years ago. Updated almost 9 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
02 November 2011
Due date:
% Done:

100%

Estimated time:
2:00 h

Description

As described here:
https://www.joomlapolis.com/forum/147-potential-bug/180869-mass-mail-problem#180869

I was able to reproduce on Joomla 1.7.2 with CB 1.7.1 having 4 test users and a single select drop down field which takes values 1,2,3,4.
All 4 test users are given the field value of 4 here.

If I use Advanced filter in CB User manager and filter using 'is' 1 and then send mass mail test, then all 4 users will receive emails just fine.

If I use Advanced filter in CB User manager and filter using "is any one of' '1,2' selected then filter seems ok as it produces all 4 test users but mass email does not send to any of them.

2950.patch (2.66 KB) 2950.patch beat, 02 November 2011 11:57 PM

History

#1 Updated by beat almost 9 years ago

  • File 2950.patch 2950.patch added
  • Status changed from New to Closed
  • Assignee set to beat
  • Target version set to CB 1.7.1
  • % Done changed from 0 to 100
  • Estimated time set to 2:00 h

that was a wierd one: search "any of" single-select are converted by jquery into multi-fields, but that happened after ajax was sending mass-mail form + click on hidden fields didn't work correctly. Now fixed order and method.

Fixed in CB 1.7.1,
Patch attached.

Also available in: Atom PDF